Game Updater in GMS isn't working.

Posted by amkgames
Hello Size43,

I am using GameMaker Server Extension 1.8.8 (Windows).
My game is not updating, I have tried using gms_update_progress to check and it stucks at 0.77.


Thanks! :)

Edit: Let me try making a new small test project. Edit2: Same thing.

Replies (31)

Last message on 11 Aug 2016

Size43 (Administrator) on 9 Jul 2016, 21:15:25
Looks like a bug. Would you mind mailing that small test project to me?
amkgames (Topicstarter) on 23 Jul 2016, 19:38:00
Weekend... Hope to get a reply.
Size43 (Administrator) on 23 Jul 2016, 20:40:26
amkgames (Topicstarter) on 19 Jul 2016, 13:17:54
Found what's wrong with it?
Size43 (Administrator) on 25 Jul 2016, 17:22:29
Apologies for the delay. I've been working a lot in the past few weeks, at some points up to 10 hours a day. That left very little time for me to do anything besides work.

Just to confirm -- are you still having issues? It seems to download fine on my end.
amkgames (Topicstarter) on 26 Jul 2016, 07:29:01
May I know following things?:
Which version of GMS are you using?
Which download link are you using for updater?
Size43 (Administrator) on 26 Jul 2016, 17:13:21
I'm using GM:Studio 1.4.1757 with the latest version of GameMaker Server.

I simply ran the file you sent me, and it downloaded and applied the update.
amkgames (Topicstarter) on 26 Jul 2016, 17:15:55
WOW! I'm using GM:Studio 1.4.1749.
Size43 (Administrator) on 26 Jul 2016, 17:20:11
Hang on -- I think I might know the problem. Try exporting to an executable, and check if that works.
amkgames (Topicstarter) on 26 Jul 2016, 17:24:57
It might be the problem, I should do a fresh GM install.
amkgames (Topicstarter) on 26 Jul 2016, 17:23:49
My GM:Studio Compiler is not working anymore! :O
Size43 (Administrator) on 26 Jul 2016, 17:33:35
Yeah that confirms what I was thinking. When debugging, GM:Studio does not actually create an executable anymore -- it re-uses a default runner.exe. That means the updater will overwrite the runner.

Everything I try to run in GM:Studio right now just ends up being your game :P

So yeah, reinstall and only run the updater on actual executables :)
amkgames (Topicstarter) on 29 Jul 2016, 12:39:30
May you export updater file to exe and send me?
It might help us to solve this problem.
amkgames (Topicstarter) on 28 Jul 2016, 19:29:31
The problem still persists, I wonder what is wrong. Could it be connection problem?
Size43 (Administrator) on 29 Jul 2016, 21:32:32
Which one? The restart or the download error?

For the second one: Try renaming your project -- Windows needs admin privileges to run files with names containing things like "update" or installer.
amkgames (Topicstarter) on 1 Aug 2016, 20:48:44
Okay, It is working fine in my cousin's pc. I guess, my pc or network/connection is problem.
Size43 (Administrator) on 1 Aug 2016, 20:50:07
Yeah, that seems like the most likely explanation.
amkgames (Topicstarter) on 1 Aug 2016, 20:52:04
I wonder, how can it be fixed?
Size43 (Administrator) on 1 Aug 2016, 20:58:35
I don't know. The extension just uses HTTP to download the file, so there would have to be something wrong with the TCP stack of your OS. Any difference between the Windows version of your PC compared to your cousin's?
amkgames (Topicstarter) on 2 Aug 2016, 07:38:49
I found that even GM8 version updater is not working now, it used to work before in this pc.
So many updates were installed after it and I didn't test the updater till now, something must be changed.
Size43 (Administrator) on 10 Aug 2016, 20:32:05
What OS are you using?
amkgames (Topicstarter) on 10 Aug 2016, 20:37:01
Windows 10 64-bit
Size43 (Administrator) on 10 Aug 2016, 20:51:02
Weird. Could you check if the one I compiled works?
amkgames (Topicstarter) on 11 Aug 2016, 07:13:52
OMG! Updater is working now, even my updater is working. :D Thank you! :)
amkgames (Topicstarter) on 2 Aug 2016, 07:39:14
Windows Updates*
amkgames (Topicstarter) on 31 Jul 2016, 08:27:20
Download error.

Tried, It is not working as well...
amkgames (Topicstarter) on 26 Jul 2016, 17:36:52
Oh, Okay. Thanks! :)
amkgames (Topicstarter) on 26 Jul 2016, 07:23:19
Size43 (Administrator) on 26 Jul 2016, 17:18:34
So what happens when an update is being applied is that the old exe is renamed, the downloaded file takes its place, and then the game runs the new exe.

In this case it seems that the game is unable to run the new exe, for some reason.
amkgames (Topicstarter) on 26 Jul 2016, 06:58:00
It is still same. Even with the newer version of Game Maker Server.
Maybe I should change download link.
amkgames (Topicstarter) on 10 Jul 2016, 06:33:45