LoadLibraryA Failed

Posted by aridale
Hey this just started happening yesterday on my laptop. This same project works fine on my PC at home but on my laptop I get this in my compile log every time. The game still runs but wont go past login, I'm guessing because the dll isnt actually loaded to handle the connection. Another game works just fine at home and on the laptop. The only difference I can find is that the one with this issue is using a newer version of the plugin.

I just started this project last week so I DLed the newest version of the plugin. Like I said this ONLY happens on the laptop. My desktop at home is fine.

Heres the log. Its very long, too long to post here

Attempting to set gamepadcount to 12
LoadLibraryA failed with error code 126

this line repeats 192 times according to a paste in notepad

LoadLibraryA failed with error code 126
Unable to find output device "null" defaulting to "Speakers (Realtek High Definition Audio) via DirectSound"
Replacing window 6
Total memory used = 1995279(0x001e720f) bytes
Attempting to set gamepadcount to 0

Like I said. It still runs fine with no errors but it wont do anything beyond showing a login screen

Replies (3)

Last message on 10 Mar 2019

Size43 (Administrator) on 10 Mar 2019, 19:23:48
You could try reinstalling the universal C runtime from here:https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows
aridale (Topicstarter) on 7 Mar 2019, 22:01:29
ok! I can officially confirm its something to do with the 2.1.4 version of GMS. In my first post I mentioned how I have an older project using an older version of the extension that works fine. So I copied the extension from that project to my desktop so I had a backup then added the 2.1.4 version of the plugin to the project that was working just fine... and it now does the exact same errors as the project I started this thread about.

Just to make sure I deleted the plugin again in Studio and imported the older version again and the project worked flawlessly again.

So something with the DLL from version 2.1.3 and 2.1.4 changed enough that it completely breaks GMS on my laptop for some odd reason.

So if anyone knows how the DLL was compiled it could help narrow down which version of vcredist I may be missing to get it working. At least thats my only theory right now
aridale (Topicstarter) on 7 Mar 2019, 21:44:28
Well still no luck on my end with this... I've tried everything I can think of or find on google related to this error (in anything not just GMS or GM) and it still gives the same error every time.

Updated all vcredist runtimes for x64 and x86
Cleaned the cache and recompiled the game
Completely uninstalled and reinstalled GM Studio 1.4

I'm at a completely loss. How did it go from working fine one day to this crazy error overnight but also completely not effecting any other program or project Ive tried... makes no sense