doesnt work on my game maker studio

when i try to use gms on game maker studio everything seems normal but when i try to test or compile it appears an error screen on white and it wont let me compile or test how can i fix it or do something for it?
PLEASE HELP!!! (sorry if my english is bad :p)
and this errors are on the console
Error : gml_Script_XGms_undef_ined(1) : unknown function or script is_undefined
Error : gml_Script_gms_connect(13) : unknown function or script network_set_config
Error : gml_Script_gms_session_player_count(3) : unknown function or script is_undefined
Error : gml_Script_gms_session_type(3) : unknown function or script is_undefined
Error : gml_Script_gms_session_tag(3) : unknown function or script is_undefined
Error : gml_Script_XServer_step(802) : invalid token
Error : gml_Script_XServer_updateposition(155) : unknown function or script angle_difference
Error : gml_Script_XServer_updateposition(170) : unknown function or script is_undefined
Error : gml_Script_XServer_updateposition(175) : unknown function or script is_undefined
Error : gml_Script_xGms_bdb_open(5) : invalid token
Error : gml_Script_xGms_bdb_get(1) : invalid token
Error : gml_Script_gms_bdb_close(2) : invalid token
Error : gml_Script_gms_bdb_seek(2) : invalid token
Error : gml_Script_gms_bdb_tell(2) : invalid token
Error : gml_Script_gms_bdb_size(2) : invalid token
Error : gml_Script_gms_bdb_read_real(2) : invalid token
Error : gml_Script_gms_bdb_read_string(2) : invalid token
Error : gml_Script_gms_bdb_write_real(2) : invalid token
Error : gml_Script_gms_bdb_write_string(2) : invalid token
Error : gml_Script_XGMs_remove_undef_ined(1) : unknown function or script is_undefined
Error : gml_Script_XServer_is_real(1) : unknown function or script is_int32
Error : gml_Script_XServer_is_real(1) : unknown function or script is_int64
Error : gml_Script_XServer_is_real(1) : unknown function or script is_bool

Replies (4)

Last message on 9 Dec 2018

Size43 (Administrator) on 27 Nov 2018, 16:05:50
Either your GM:Studio version is outdated, or you're using the (All) version in GM8.

If you're using GM8/8.1 you must use the GM8 version of the extension.
BonniekawaiidesuG (Topicstarter) on 7 Dec 2018, 20:03:17
nope im using the gms version of the extension
jdev on 9 Dec 2018, 15:22:41
Are you using GM:Studio or GM8?
jdev on 9 Dec 2018, 17:35:46
Sorry, I misread your thread. Try using the Windows version of the extension, or try updating your GM:Studio to a more up-to-date version.